Incident with Projects Storage, Releases and Manufacturing, Design Review & Sharing on Web, Components and Supply Chain, MCAD CoDesigner, User Identity

Incident Report for Altium 365 GovCloud

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 20:56 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 20:45 PDT

Identified

The issue has been identified.
Posted Jun 12, 2025 - 20:44 PDT
This incident affected: Requirements (GovCloud-US-East), MCAD CoDesigner (GovCloud-US-East), Design Review & Sharing on Web (GovCloud-US-East), Projects Storage (GovCloud-US-East), Releases and Manufacturing (GovCloud-US-East), Components and Supply Chain (GovCloud-US-East), and User Identity (GovCloud-US-East).